Status: 

Vuo version: 

OS version: 

  • Mac OS 10.9

Steps causing the bug to occur: 

  1. Create Composition with file path (such as an image)
  2. Save Composition
  3. Make Composition into Vuo Node from "file make node"
  4. Node & Composition no longer loads resources from the file paths

How did the result differ from what you expected?: 

I would expect the file paths to be updated when moved into the modules folder, or alternatively resources to be copied into the modules folder. (Possibly Packaged in a folder named after the node to keep everything together?)

Have you found a workaround?: 

Manually changing the file path of the resource (or dragging and dropping the same resource back into the editor)

Comments

I would expect the file paths

smokris's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Scheduled for work

I would expect the file paths to be updated when moved into the modules folder, or alternatively resources to be copied into the modules folder.

Yes, we're planning for the editor to give you the option to copy files into the Modules folder, then update the relative paths accordingly. This bug report covers that.

(Possibly Packaged in a folder named after the node to keep everything together?)

There's a feature request for that: Ability to bundle resources (images, movies, other files) along with a composition

What if it packaged them in

cwilms-loyalist's picture
Submitted by

What if it packaged them in some kind of file wrapper that had the composition and the folder with the graphics and other resources inside kind of like how apps have "Show package contents". then is would remain as one file that can easily be moved and shared and could be edited if required.