There are three attachments

mandurah1 is the final installation, internal projection, two projectors, two spherical mirrors and my warping.

screenlayout shows the two external screens attached to the laptop ports, HDMI and DisplayPort.

player.vuo is the vuo application, some nodes disconnected in order to try and isolate the problem.

What happens is that the windows do not open up on the displays as expected. Sometimes one works and not the other, sometimes the other way around. Is there another way to do this?

Suggestions welcome. The way around is of course to manually drag the windows to the correct display and manually enter full screen, but not desirable.

Comments

Does it help if you take the

useful design's picture
Submitted by

Does it help if you take the Requested Frame outputs and wire them to the Play Movie node or some other patch just to keep the events flowing?

For what it's worth, I changed the window positions so one is placed on my Retina display (0,0) and the other on my external display (2000,0) and both windows appeared 10 times in 10 restarts of the comp (with no other changes to comp).

Thanks for the offer, but don

pbourke's picture
Submitted by

Thanks for the offer, but don't worry about it for now. I'll test later this afternoon or tomorrow and report back. On site in the dome shown in the original post was not the right place to debug things while the client was watching, I'm sure I'll be able to isolate the issue in the more relaxed home environment. :-)