unexpected image softening/ghosting using Vuo made FxPlugs

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • macOS 10.14

Steps causing the bug to occur: 

  1. use Vuo 2 beta to create what should be a passthrough effect where there is no apparent change to the video on the output, and export an FxPlug of such a comp
  2. in Motion or FCP, apply the FxPlug to some video and magnify the image in the viewer a bit and toggle the FxPlug effect on and off carefully looking at the image
  3. I am seeing the image seem to slightly soften and shift to the right unexpectedly when the effect is enabled
  4. watch a short screen cap video with voiceover here to see a demonstration of the problem here ; http://www.kingluma.com/pass_through.mp4
  5. I'm on the latest versions of Motion and FCP (Motion 5.4.4 & FCP 10.4.7) and I only have one Mac to test on (MacBook Pro) at the moment and here are the graphics specs ; AMD Radeon R9 M370X:

    Chipset Model: AMD Radeon R9 M370X Type: GPU Bus: PCIe PCIe Lane Width: x8 VRAM (Total): 2 GB Vendor: AMD (0x1002) Device ID: 0x6821 Revision ID: 0x0083 ROM Revision: 113-C5670E-945 VBIOS Version: 113-C567A1-006 EFI Driver Version: 01.00.945 Automatic Graphics Switching: Supported gMux Version: 4.0.20 [3.2.8] Metal: Supported, feature set macOS GPUFamily2 v1

and MBP details ; Model Name: MacBook Pro Model Identifier: MacBookPro11,5 Processor Name: Intel Core i7 Processor Speed: 2.5 GHz Number of Processors: 1 Total Number of Cores: 4 L2 Cache (per Core): 256 KB L3 Cache: 6 MB Hyper-Threading Technology: Enabled Memory: 16 GB

Have you found a workaround?: 

no

Other notes: 

this doesn't block me from continuing work to develop FxPlugs with Vuo but the rendering issue seems like a must fix for a final release

Page not found error for "How ISF source code translates"

eseftel's picture

Status: 

Vuo version: 

OS version: 

  • macOS 10.14

How severely does this bug affect you?: 

●○○○ — Not much; I'm just letting you know about it.

Steps causing the bug to occur: 

  1. File...New Shader...Image Generator
  2. Under ISF Extensions, click on link for How ISF source code translates to a Vuo node

trouble with sub-compositions . . .

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • macOS 10.13

How severely does this bug affect you?: 

●●●○ — It prevents me from completing a specific task with Vuo.

Steps causing the bug to occur: 

  1. create sub-composition
  2. save it to the user folder
  3. composition runs perfectly
  4. export app, it won't run properly (extremely slow)
  5. then VUO will no longer open without a restart of laptop

Have you found a workaround?: 

No, well, except to reboot.

Other notes: 

The crash log I have included is just one of many as I'm trying to find a work-around. Perhaps I am building my sub-compositions incorrectly, but I have found V2.0 to be be very unstable in regards to sub-compositions and nodes in the user library.

Thank you in advance for any help/advice you can offer.

Compositions: 

AttachmentSize
Package icon Lighting Visualizer.zip12.2 MB

Crash reports: 

AttachmentSize
Plain text icon Crash Log.txt131.72 KB

`Get Audio Input Values` outputs ID -1 and Channel Count 0 when input is constant value (input editor instead of cable)

Status: 

Vuo version: 

Fixed in Vuo version: 

Steps causing the bug to occur: 

See Audio Device has no channels.

Some of the other Get * Input/Output Values nodes behave similarly. They expect their input to come from a List * Devices node, in which case they do output the actual device's values.

Unexpectedly quit(s)...

prackvj's picture

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • macOS 10.14

How severely does this bug affect you?: 

●●○○ — It's annoying but I can work around it.

Steps causing the bug to occur: 

  1. Hi, I'm experience some Unexpectedly quits... sometimes doing nothing... working on other apps with almost nothing working on Vuo.... Today I installed the MacPorts and Xcode and the Command Lines for Xcode, for the Kinect. I don't know if this has relation with the crashes...
  2. I attached a texfile with the Apple's description. Thanks!

Crash reports: 

AttachmentSize
File crash1.rtf112.85 KB

Pages

Subscribe to RSS - Resolved