Instant crash with Resolume

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • macOS 10.14

How severely does this bug affect you?: 

●●●● — It prevents me from using Vuo at all.

Steps causing the bug to occur: 

  1. Creating FFGL plugin for Resolume Arena as exactely as explain in your tutorial
  2. Once in Resolume (7.2.0), everytime I try to applied the effect, Resolume crash instantanely

Have you found a workaround?: 

Nope; I try all the way you explain in your tutorial (https://www.youtube.com/watch?v=d1RwWbJrPbk) and each example have the same issue...

Other notes: 

I just bought a license to do this task, I hope I didn't lose my money...

App exported on macOS 10.15 won't run on earlier version of macOS

Status: 

Vuo version: 

Fixed in Vuo version: 

Steps causing the bug to occur: 

The NDICast v1.0 app shared by cwilms-loyalist fails to launch on macOS 10.14, as reported by Joe.

Other notes: 

If you re-export the composition to an app on macOS 10.14, it launches.

2.1 Not running

micpool's picture

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.10

How severely does this bug affect you?: 

●●●● — It prevents me from using Vuo at all.

Steps causing the bug to occur: 

  1. Open a .vuo file that runs perfectly in 2.03
  2. Run
  3. Nothing happens
  4. I have tested all my files and none of them work
  5. Run indicator turns for about 5 secs and composition returns to stopped state.

Other notes: 

Reverted to previous version

Receive MIDI events node crash with Sysex overload

micpool's picture

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.10

How severely does this bug affect you?: 

●●●○ — It prevents me from completing a specific task with Vuo.

Steps causing the bug to occur: 

  1. Connect a MIDI input to the MAC that has a lot of MIDI sysex. In my case I am using a Roland Octacapture which communicates with its Mac editor through Sysex on a MIDI port named MIDI CNTRL It sends packets of 29 bytes of sysex repeatedly when the editor is open. This port appears in the MIDI input list in Vuo.

Have you found a workaround?: 

Not selecting that interface. However this is quite difficult to do, as the only way I have found of selecting on screen which interface to use is by stepping through the interfaces, either with a slider or dec/inc buttons.

Other notes: 

I think this will be a problem with any MIDI device which sends lots of sysex data as part of its MIDI spec.

Screenshots: 

Compositions: 

AttachmentSize
Binary Data Receive MIDI events Bug.vuo1.3 KB

Crash reports: 

BUG : Command line render actually renders node graph , not composition!

Status: 

Fixed in Vuo version: 

Steps causing the bug to occur: 

When using the command-line vuo-render command, one would expect the composition result to be rendered.

Instead , the canvas representing the node graph layout is rendered,

vuo-render --output-format=png --output renderx.png /Users/iMac2012/Desktop/VUO/VUO2/vuo-2.0.3-composition-examples/vuo.image/examples/QuickStart.vuo

Rendered Image

I was expecting this instead :

Screenshot

Screenshots: 

Pages

Subscribe to RSS - Resolved