Anchor points doesn't work (at least not in layer.make.roundedRectangle)

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.11

How severely does this bug affect you?: 

●●●○ — It prevents me from completing a specific task with Vuo.

Steps causing the bug to occur: 

  1. Create layer.make.roundedRectangle
  2. Set Anchor to any other anchor point than center
  3. Make rectangle height bigger than width
  4. Anchor point flips to another place

Have you found a workaround?: 

No

Other notes: 

If this is meant to work like this, please explain why, I don't understand the logic?

Screenshots: 

Compositions: 

AttachmentSize
Binary Data PositionBug.vuo7.67 KB

Pathes with vuo.math.calculate don't work on case-sensitive file system

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.11

How severely does this bug affect you?: 

●●●○ — It prevents me from completing a specific task with Vuo.

Steps causing the bug to occur: 

  1. Create new composition
  2. add vuo.math.calculation to the composition
  3. Run
  4. -> "There was a problem running the composition" error message, details "Node outdated or broken...check the Console application"
  5. -> Console application show error "Vuo Editor: VuoCompiler.cc:2077 getLinkerInputs() Warning: Could not locate dependency 'muParser'."

Have you found a workaround?: 

Avoid using vuo.math.calculate -module. Almost all equations I need can be done with combination of add, substract, multiply -modules, but I would also need modulo -operator.

Other notes: 

I think that this is so fundamental module that it have to work with most of people. So, there have to be some conflict with vuo and my system.

My guess is that problem could be that I have case sensitive file system, which is not the default option in osx (but still an option in normal osx install). Maybe muParser is called with wrong casing somewhere,..just a guess.

texture mapping a .ply

Status: 

Fixed in Vuo version: 

Steps causing the bug to occur: 

I've been using the app called TRNIO to generate a 3d model (.ply) and texture and I'm having trouble assigning the texture to it. Actually I can assign the texture to it but it's not acting as it should here

http://trn.io/b/blEJaQKsLD/

Suggestions? Really fun to play with.

Compositions: 

'Render Image to Window' doesn't render image if less than 4px in height

Status: 

Vuo version: 

Fixed in Vuo version: 

Steps causing the bug to occur: 

As reported by bLackburst on Make Noise Image Range doesn't cover small resolutions:

Also if you render this [1-pixel-high] image to a window you will notice that the window doesn't display this line unless the window is resized.

Auto type-convertor bug

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • macOS 10.12

How severely does this bug affect you?: 

●○○○ — Not much; I'm just letting you know about it.

Steps causing the bug to occur: 

  1. "Get Layer Values" transform port connected to "Make oval Layer" width and height defaults to rotation instead of scale.

Pages

Subscribe to RSS - Resolved