Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.11

How severely does this bug affect you?: 

●●●○ — It prevents me from completing a specific task with Vuo.

Steps causing the bug to occur: 

  1. Create new composition
  2. add vuo.math.calculation to the composition
  3. Run
  4. -> "There was a problem running the composition" error message, details "Node outdated or broken...check the Console application"
  5. -> Console application show error "Vuo Editor: VuoCompiler.cc:2077 getLinkerInputs() Warning: Could not locate dependency 'muParser'."

Have you found a workaround?: 

Avoid using vuo.math.calculate -module. Almost all equations I need can be done with combination of add, substract, multiply -modules, but I would also need modulo -operator.

Other notes: 

I think that this is so fundamental module that it have to work with most of people. So, there have to be some conflict with vuo and my system.

My guess is that problem could be that I have case sensitive file system, which is not the default option in osx (but still an option in normal osx install). Maybe muParser is called with wrong casing somewhere,..just a guess.

Comments

Yes, I think you're right

jstrecker's picture
Submitted by

Yes, I think you're right about case-sensitivity being the issue. I'm glad you pointed that out, or it might have taken us a while to guess! The nodes that refer to the library (including Calculate, Calculate List, Make Parametric Grid Mesh, and Make Parametric Points) call it "muParser" when it should be "muparser".

Until we get this fixed, you may be able to work around the problem by renaming the library file:

  • Right-click on your Vuo Editor.app file and choose Show Package Contents.
  • Go to Contents > Frameworks > Vuo.framework > Versions > Current > Modules.
  • Rename libmuparser.a to libmuParser.a.
  • Go to Finder. (For example, click on your Desktop so that the menu bar says "Finder".)
  • Hold down the Option key and select Go > Library.
  • Go to Library > Caches > org.vuo.
  • Delete the folder whose name corresponds to your current version of Vuo (e.g. 1.2.6).
  • Restart Vuo Editor. (It will take longer than usual to start since it will need to rebuild the cache you just deleted.)