VT's picture

Hi All

I just started using Vuo and I'm having some performance issues when i try to manipulate several parameters in my Vuo comp with a Lfo in VDMX.

My performance drops from 60 fps to 30 fps when I start running the Lfo in my VDMX example project and sending values to the Vuo image generator.

The Vuo comp is very "light" and should run at 60 fps.

Any tips on how I can improve my performance ?

Thanks.

-Piotr Pajchel

Comments

Piotr,

jmcc's picture
Submitted by

Piotr,

We haven't tested the composition, but one of my colleagues suggested hooking up the time port. VDMX seems to work better when the width, height, and time ports are all connected to nodes in the composition. Generally, it's also not a good practice to use nodes that create their own events within an image generator composition. So, you can use a cable from the time port to an "Allow First Event" node, where the output event would then go to the "Make Wireframe Shader" and perhaps the "Make 3D Point" nodes. Let us know if that helps.

Hi

VT's picture
Submitted by

Hi

I tried your suggestions and performance didn't Improve, I did some similar test with a QC cube (see new preste in VDMX project) which runs fine with the same LFO input. Since I'm new to Vuo its hard for me to tell if I'm doing something wrong or if there is a general performance issue with Vdmx LFO data driving a Vuo comp. .

-Piotr

Thanks Jean Marie

VT's picture
Submitted by

Thanks Jean Marie

I see.

I will have to work around this limitation for now.

Is there a similar performance limit on OSC messages ?

In general only six Lfo (or any variable input from VDMX) seems very limiting, would it be possible to improve this Vdmx-Vuo communication in the future ?

-Piotr

Piotr,

jmcc's picture
Submitted by

Piotr,

Yes, that's an result we did not expect. We are doing some further investigation, and I'll report back when I have more information. We've never used OSC with VDMX, so I can't predict the performance.

Piotr,

jmcc's picture
Submitted by

Piotr,

We did some more investigation:

  • When exactly the problem happens — when VDMX rapidly sends a series of changing parameters into several published input ports in a Vuo composition, such as when using LFOs.
  • It's unrelated to Vuo's Send/Receive OSC Messages nodes.
  • Why it happens — unnecessary work is being done in the communication between VDMX and Vuo.
  • Actions Team Vuo is taking — We will make communication on Vuo's end more efficient in the next Vuo release, and have contacted the VDMX developers to suggest how they can make it more efficient on their end.
  • Work around — Move the LFO performance into Vuo using Wave or Curve nodes. Then set up your published ports to select the Wave node, Curve node, or constant value you want to use. You can also used published ports to control the input values to the Wave or Curve nodes. I've included an example that runs at 60fps on my system.

Hope that's helpful,
Jean Marie