Status: 

Vuo version: 

OS version: 

  • macOS 11

CPU architecture: 

Intel x86_64

How severely does this bug affect you?: 

●●●○ — It prevents me from completing a specific task with Vuo.

Steps causing the bug to occur: 

  1. Connected known good Arduino Leonardo (which works as HID Gamepad on Mojave and generates X,Y,Z Values with Quartz Composer) to Machine, which is recognised in System Information USB Device Tree as "Arduino Leonardo"
  2. Tried to retrieve device with "Specify HID by Name", at different times with either "Leonardo", "Arduino Leonardo", or even without specifying a name and just using the HID "Gamepad" settings
  3. when generating X,Y,Z events on the device, no controls are received.

Have you been able to reproduce the problem?: 

●●● — Yes, the problem occurs consistently when I follow the steps above

Have you found a workaround?: 

No

Comments

On the Receive HID Controls

jstrecker's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Waiting for more information from reporter

On the Receive HID Controls node, if you double-click on the Device port, that brings up a little menu. Is your Arduino Leonardo listed in that menu?

If it is listed in the menu, then select it, run the composition, and click on the Received Control output port. This brings up a popover showing the information coming through the port. Does it show any data coming through?

If your Arduino Leonardo is not listed in the menu or the Received Control port isn't outputting anything, does Tools > Show Console have any messages related to HID?