Status: 

Vuo version: 

OS version: 

  • Mac OS 10.10

Steps causing the bug to occur: 

  1. run a vuo patch using add noise to 3D object
  2. intermittent crashes when running in VDMX

How did the result differ from what you expected?: 

this is the same crash that occurs running vuo 1.1.1 patches in VDMX

Have you found a workaround?: 

avoid using add noise to 3d object node

Comments

Azy, could you attach a few

smokris's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Waiting for more information from reporter

Azy, could you attach a few of the crash reports? (You can find them by launching Console.app and checking under the "User Diagnostic Reports" section. If VDMX itself is crashing the crash reports will start with VDMX, otherwise their names should start with your composition's name.)

Which version of VDMX are you using? Do you have VDMX configured to run Vuo compositions in-process or in separate processes? Which GPU does your system have? Could you attach the Vuo composition that's crashing?

(I just tested an Image Generator composition using Add Noise to 3D Object in VDMX5 version b0.8.5.0.4, both in VDMX's in-process and separate-process mode, and I haven't yet been able to reproduce the crash.)

Thanks, Azy. It's crashing

smokris's picture
Submitted by
Status:
Waiting for more information from reporter
»
Resolved

Thanks, Azy. It's crashing in gleLookupHashObject, which indicates this is the same OpenGL driver bug you, Dave, and Jaymie (@jstrecker) discussed a couple months ago.

We added a workaround for this driver bug in Vuo 1.2, so hopefully you will no longer experience this crash once VIDVOX publishes a new VDMX release that uses Vuo 1.2. (VDMX5 version b8.5.0.7 uses Vuo 1.1.1.)