Hi there, I made myself a little Mask creation tool in order to create a super flexible mask. It runs great inside VUO and also exporting is not a problem. I made sure all the signals coming throgh the input ports are reaching the final output port as well. If i load the vuo composition (using the media bin, and also putting it into the VDMX path to show up as Image Source) the composition wont run. I dont get any error messagges from VDMX and the composition shows in the media bin just fine. If i trigger it it only gives me a still image. everytime i retrigger it the image is different, but it wont move. Any help would be appreciated. I've been trying things for way to long :)

I tried to use other Image generator composition downloaded from the gallery but i do get the following error when opening VDMX : There was a problem loading the composition A: Warp Speed.vuo. This composition contains nodes that are neither built in to this version of Vuo nor installed on this computer: vuo.event.allowChanges.VuoInteger (Allow Changes) vuo.image.feedback (Blend Image with Feedback)

both nodes are available inside vuo and the compositions work fine there... ://

Comments

The problem is that VDMX is

jstrecker's picture
Submitted by

The problem is that VDMX is still using Vuo 1.1. There are some new nodes in Vuo 1.2 that weren't in 1.1, and there are some nodes that changed how they work. (For more info about why VDMX uses a different Vuo version than your Vuo Editor, see Are there plans to make Vuo a system-wide service?)

Until VDMX releases an update that includes Vuo 1.2, I'd recommend testing compositions in Vuo Editor 1.1 (available at https://vuo.org/releases) before running them in VDMX.

Your Super Mask composition looks quite different in Vuo 1.1 than in Vuo 1.2, and that's because the Copy Layer nodes changed how they work. As of Vuo 1.2, they respect the transform of the input layer, whereas before they ignored it. When your composition runs in Vuo 1.1, the Copy Layer with Transform node applies the input transforms by themselves instead of applying them on top of the center, rotation, width, and height from the Make Rounded Rectangle Layer node. The attached composition demonstrates a workaround. (The numbers probably need to be adjusted.)

Hi Jamie. Thx for the reply.

boomshokka's picture
Submitted by

Hi Jamie. Thx for the reply. Its a shame the newer version is not compatible with VDMX ;/ I did change all the transformation and readjusted the values. It was still not working so I tried adding individual nodes to test the version in VUO. I realized that I had to remove the rotateImage node in order for the composition to work properly in VDMX. I would like to be able to change the direction of the arrows with a rotation node inside Vuo. Is there any workaround as well? I have also realized that the published dropdown menus from Mirror Image and Blending Mode for example are not showing up in VDMX. is there a way to control these menus with a slider perhaps?