Status: 

Vuo version: 

OS version: 

  • macOS 10.12

Steps causing the bug to occur: 

  1. Install USBOVERDRIVE http://www.usboverdrive.com/USBOverdrive/News.html
  2. Start Vuo, and pull a cable around the composition
  3. Move composition with mouse wheel
  4. cable disappears

Have you found a workaround?: 

Disable USBOverDrive

Other notes: 

I am using USBOverDrive as there is an annoying bug? issue? feature? of Sierra that causes single scroll wheel clicks not to be picked up. So you end up having to scroll 3 click to move in any direction.

USBOverDrive is a solution to this issue, but causes Vuo to exhibit the above behaviour.

Comments

@alexmitchellmus, you're

jstrecker's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Waiting for more information from reporter

alexmitchellmus, you're seeing the "single scroll wheel clicks not picked up" system-wide, not just in Vuo, right?

Could you describe your settings in USB Overdrive? We tried to reproduce the "cable disappears" problem and so far haven't been able to, possibly because of different settings. The only settings we changed from the defaults were "Wheel Up" and "Wheel Down" to both scroll by "30 lines".

Thanks for checking this out

alexmitchellmus's picture
Submitted by

Thanks for checking this out @jaymie!

I am using a normal mouse- not a Magic Mouse- or trackpad.

I didn't change any settings for usboverdrive- simply enabled it. The issues that I was trying to resolve was scrolling in Sierra only kicks in after about 3 scroll wheel clicks. Very annoying! But obviously this caused another issue with Vuo on my system.

I can post a video regarding this issue. The problem with Vuo is resolved by disabling usboverdrive, so maybe I can find another way to fix my scroll issue in Sierra? There are multiple online forums discussing this new scroll behaviour, so there may be other solutions! ;-)

We are able to reproduce the

jstrecker's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Not a bug

We are able to reproduce the problem with macOS 10.12.1 and Vuo 1.2.4.

The problem seems to be that USB Overdrive is outputting bogus mouse events. This seems to be a well-known problem with USB Overdrive that affects many applications. See for example here.

We looked into whether there might be an easy workaround we could add to Vuo, and there's not. It would require a lot of modifications to Qt, the UI framework used by Vuo.

Since it's a bug in USB Overdrive, a utility that is needed to work around a bug in macOS, I'd recommend contacting those developers.