Status: 

Vuo version: 

OS version: 

  • macOS 10.12

How severely does this bug affect you?: 

●●○○ — It's annoying but I can work around it.

Steps causing the bug to occur: 

  1. Create a sub-composition with some published ports
  2. Erase one of the published ports (input or output)
  3. Create a new published port with the same name and place as the erased port (input if erased one was input, output if erased port was output)
  4. Result is the digit "2" appended to the port title.
  5. Rename port to erase the "2" and it becomes a "3"

Have you found a workaround?: 

No.

Other notes: 

It means that when reworking a sub composition you can break wires coming out of it in the parent compositions because it forces a port title change on you which, which obviously breaks the link to other nodes in the parent compositions. Forced to rewire them, and an annoying port name too.

Comments

I haven't been able to

jstrecker's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Waiting for more information from reporter

I haven't been able to reproduce this. Alastair (@usefuldesign), did I miss any steps?

Start with subcomposition with published ports:

Delete a published input port

Add a published input port of the same name back in:

Hi Jaymie (@jstrecker) when I

useful design's picture
Submitted by

Hi Jaymie (@jstrecker) when I simply replicate a vuo file the same as yours (Make Color Layer patch only) I don't get the bug.

But when I'm working on sub compositions used in my own Vuo files I consistently have this problem. See screenshot. Attached a sub-composition for you to examine. Try creating an output called acceleration. Not possible for me, Vuo will always append the lowest number not used by another output port already. Even if I delete all the output ports first.

That's because you have a

jstrecker's picture
Submitted by
Status:
Waiting for more information from reporter
»
Merged

That's because you have a published input port with the same name. The names are restricted to be unique across all published ports, input and output.

Although not a duplicate of this bug report, the same solution would apply. So I'm merging this bug report with that one.