DRDN's picture

Status: 

Vuo version: 

OS version: 

  • macOS 10.14

How severely does this bug affect you?: 

●●●● — It prevents me from using Vuo at all.

Steps causing the bug to occur: 

  1. working on a node
  2. safed the node
  3. Crash 4.Any try to reopen Vuo won't work

Have you found a workaround?: 

No. Restarting and redownloading the editor won't work.Also cleared out the cache of the programm

Other notes: 

Need really fast help on this please

Comments

@DRDN, sorry you're having

jstrecker's picture
Submitted by

@DRDN, sorry you're having trouble. Here are some things to try:

  • Uninstall any subcompositions/nodes you have installed.
    • Go to Tools > Open User Modules Folder. If there are any files in there, move them out of the folder.
    • Do the same with Tools > Open System Modules Folder.
    • Restart Vuo.
  • Delete Vuo's module cache:
    • Go to Finder (e.g. click on the Desktop).
    • Go to the Go menu and hold down the Option key, and select the Library option that appears.
    • Find the Library > Caches > org.vuo folder and throw it in the trash.
    • Restart Vuo.

If that doesn't fix it, could you post the crash report? You could also check Console.app for any log messages from Vuo.

As I already mentioned a

DRDN's picture
Submitted by

As I already mentioned a tried all that the last night several Times. Also tried App Cleaner. The only thing that happens when I use app Cleaner is that Vuo ask me to activate again. After that immediately in the old loop. I noticed in the User Modules folder when I deleted all the nodes I wrote and try to start the Prorgamm again. All the files will be recreated.

Nov 30 11:35:07 Arians-Air

DRDN's picture
Submitted by
Nov 30 11:35:07 Arians-Air com.apple.xpc.launchd[1] (org.vuo.editor.5040[986]): Service exited due to SIGSEGV | sent by exc handler[986]
Nov 30 11:35:14 Arians-Air Vuo Editor[990]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug
Nov 30 11:35:20 Arians-Air com.apple.xpc.launchd[1] (com.apple.xpc.launchd.oneshot.0x1000000d.Vuo Editor[990]): Service exited due to SIGSEGV | sent by exc handler[990]
Nov 30 11:35:25 Arians-Air Vuo Editor[992]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug
Nov 30 11:35:31 Arians-Air com.apple.xpc.launchd[1] (com.apple.xpc.launchd.oneshot.0x1000000e.Vuo Editor[992]): Service exited due to SIGSEGV | sent by exc handler[992]

This is the System Log

Moderator note: 

Adjusted formatting

I am really desperate now.

DRDN's picture
Submitted by

I am really desperate now. Really need all that stuff tomorrow. Put a lot of work and many Nights on this Project now. And now the whole Programm won't work any more. Never exp. something like that with other programms on my mac. And now I really don't know what to do anymore.

If this will apear more frequently I defently will get my money back for the Programm. Quartz Composer worked fine for several Years now.

Okay tried it like 20 times

DRDN's picture
Submitted by

Okay tried it like 20 times and started mac in safe mode. After then trying it back in normal mode some how it worked again. Had this node with the Flashes EQ composition in it from the Community here. Deleted that node and everything worked again.

@DRDN, I'm glad you were able

jstrecker's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Waiting for more information from reporter

@DRDN, I'm glad you were able to find and delete the problematic node. If you still have the node, could you attach it to this bug report so we can figure out why Vuo crashed? In fact, it would help even more if you could provide all of the nodes you had installed, in case the problem involves multiple nodes.

(We tried turning this Flashes composition into a subcomposition but couldn't reproduce the problem.)

@Kewl, thanks for the suggestion about AppCleaner. It seems like a useful tool in general, although in this case AppCleaner missed the folders where the problematic node would have been installed (either User Modules or System Modules). We looked into how the Vuo app could inform AppCleaner about those locations and, not finding any documentation, have asked the developers.