Status: 

Vuo version: 

OS version: 

  • macOS 10.14

Steps causing the bug to occur: 

In macOS 10.14.4, compositions with a Receive Live Video or List Video Devices node no longer work and sometimes crash.

The underlying problem is that, starting in macOS 10.14.4, a video library that Vuo uses (Appleā€™s QTKit) is broken. Other apps that use QTKit have also stopped working.

The problem will be fixed in Vuo 2.0, as it no longer relies on QTKit. See our mailing list / blog for updates on the estimated release date.

Have you found a workaround?: 

Downgrade to macOS 10.14.3 or earlier.

Comments

What do we do in the meantime

cwilms-loyalist's picture
Submitted by

OSX 10.14.3? That requires a complete reinstall of OSX right?

I might have a work around for my project using a 2nd Blackmagic UltraStudio Mini Recorder so I don't have to use the Receive Video Node but at the moment I'm having a weird conflicting issue were frames from the one Blackmagic device enter and disrupt the image of the other (along with some green flashes and lines). I didn't get this when the other camera was a webcam on the Receive Live Video node. Still testing because when I make a simple composition with both Blackmagic capture devices I haven't seen the issue yet. Both cameras are running at the same frame rate in this test so it's not the exact issue I reported before I don't think.

Same case of crash here, but

leon's picture
Submitted by

Same case of crash here, but another context: first example in trial.

I am finally thinking of migrating from QuartzComposer or at least complementing it, and considering buying VUO. But as soon as I installed the trial and want to open the first ever example, the whole program crashes. With some humor, I have to admit: " VuoVideoPlayer.cc:224 OnDecoderPlaybackReady() On second thought, AVFoundation decided it couldn't play this video." Well, I deleted the LiveVideo node and it worked. As I recall, it never asked for permissions for the FaceTime Cam, but that seems not to be the whole problem, because using the virtual camera input of MimoLive (accepted as video in CoGe) leads to a crash not of the whole program, but of the VuoCompositionLoader. Am on MBPro with OS 10.14.6.