Status: 

Vuo version: 

OS version: 

  • macOS 10.13

How severely does this bug affect you?: 

●●●○ — It prevents me from completing a specific task with Vuo.

Steps causing the bug to occur: 

Using the "Save images to movie" node, the image quality setting for H.264 doesn't seem to make any difference. I would expect a different size movie for quality of 0.5 vs 1.0.

Compositions: 

AttachmentSize
Binary Data movietest.vuo1.89 KB

Comments

It seems to be working as

jstrecker's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Not a bug

It seems to be working as expected in our testing, but let me know if you see something different.

For both H.264 and H.265, between quality 0 and 1 there's a clear size difference. Between 0.5 and 1, there's not necessarily much difference.

Vuo translates the quality slider into a bitrate value it passes to AV Foundation. If the movie can be fully encoded using a certain bitrate, then increasing the slider beyond that shouldn't increase the quality or size.

Hmmm, well you are stricktly

pbourke's picture
Submitted by

Hmmm, well you are stricktly correct, the attached shows the case for encoding quality of 0.1 and 1.0. (before I was using higher values and didn't see a difference. A few comments 1. The original movie is H264 from QuickTime Pro, so it has expanded quite a bit going through the Vuo save process. Is this possibly because each frame is a keyframe? 2. The movie size difference between a quality of 0.1 and 1.0 is "small".