micpool's picture

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • OS X 10.10

How severely does this bug affect you?: 

●●●○ — It prevents me from completing a specific task with Vuo.

Steps causing the bug to occur: 

  1. Items added to list

  2. Items added to positions list

  3. Items removed from positions list until empty

  4. Spurious item appears in output list even though the position list is empty

  5. All items removed from list so main list is empty

6 Spurious output item remains

Have you found a workaround?: 

Yes, using a different method to get the position list

see https://vuo.org/node/2656#comment-7127

Other notes: 

I've uploaded a screen capture. Because only the crash log will allow a zip, its there

Screenshots: 

Compositions: 

AttachmentSize
Binary Data arrays4.vuo8.12 KB

Crash reports: 

AttachmentSize
Package icon Get Items from List bug.mov_.zip2.49 MB

Comments

I have now reduced this

micpool's picture
Submitted by

I have now reduced this problem to a very simple composition (attached)

It would appear that the 'Get Items from List'Node is behaving differently when presented with an explicit empty list, or a list of integers which changes to an empty list. although I don't understand the difference.

In the example workspace the top example works because it checks to see of the list produced by the reverse node is populated and if it isn't sends an explicit empty list of integers. This works

The lower example just accepts that the output of the reverse list is empty when it says it is. This produces the wrong output from the Get Item node.

I hope this makes the problem clear

Thanks

Mic