Vuo 2.2.0 is very buggy

The about menu and some other controls are localized in Arabic !

There are a lot of missing standard nodes

Comments

The about menu and some other

jstrecker's picture
Submitted by

The about menu and some other controls are localized in Arabic !

In System Preferences > Language & Region, is Arabic above English in your list of preferred languages? If so, then that is the expected behavior. Although Vuo itself doesn't provide an Arabic translation, these menu items and buttons are translated automatically by macOS.

If Arabic is not above English in your preferred languages, then this is a bug. If so, to help us troubleshoot, could you provide more info, such as a screenshot of your System Preferences > Language & Region settings (both General and Apps if on macOS 10.15 or later) and your macOS version?

There are a lot of missing standard nodes

That composition was created with a much older version of Vuo (looks like 2013-2014). To update the composition so it can be used with recent Vuo versions, you can open it in Vuo 0.9 and re-save it.

My coworkers and I tested on

jstrecker's picture
Submitted by

My coworkers and I tested on several different macOS versions (11, 10.15, 10.14, 10.12), copying the settings from the screenshot above, but we haven't been able to reproduce the problem yet.

sandrobilbeisi, could you provide more information to help us troubleshoot this problem?

  • What macOS version are you using?
  • Do you also see the Arabic text in Vuo 2.1.2, or only in Vuo 2.2.0?
  • If you feel comfortable, could you try the following?
    • Launch Terminal.app.
    • In Terminal, paste the following command and hit Enter:
      • defaults write org.vuo.Editor debug -boolean true
    • Launch Console.app.
    • In Console, select "All Messages", and in the Search field in the top-right, type vuo.
    • Launch Vuo.
    • In Console, Edit > Select All, then Edit > Copy.
    • Open TextEdit.app, paste the logs, and save.
    • Attach the file to this bug report.
    • In Terminal, paste the following and hit Enter:
      • defaults delete org.vuo.Editor debug

I am using Mac OS 10.13.6

sandrobilbeisi's picture
Submitted by

I am using Mac OS 10.13.6 High Sierra

machine : iMac (27-inch, Mid 2011)

Processor : 2,7 GHz Intel Core i5

Memory : 8 GB 1333 MHz DDR3

Graphics : AMD Radeon HD 6770M 512 MB

Vuo 2.1.2 does not display any anomalies