Status: 

Vuo version: 

OS version: 

  • macOS 10.14

CPU architecture: 

Intel x86_64

How severely does this bug affect you?: 

●○○○ — Not much; I'm just letting you know about it.

Steps causing the bug to occur: 

This is probably an issue with the mac architecture but I thought I would report it anyway.

I noticed performance issues when recording using the "save images to movie" node. In the mac Activity Monitor I can see a process appear called VTEncoderXPCService. This uses 125% CPU or similar. This process opens only when I record to JPG, ProRez etc. I can easily force close this process to zero effect. This makes me think it's a bug. The H264 format doesn't launch this process.

Have you found a workaround?: 

If I want to use those formats I can simply force close the process. 4444 records the alpha channel so it's a desirable format.

Comments

Unfortunately that's not

jmcc's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Not a bug

Unfortunately that's not something we have any control over when using Apple's framework to encode video; macOS launches the VTEncoderXPCService process automatically.

If this problem causes Vuo's Save Images to Movie to not keep up with video encoding, there are a few options:

  • Use offline rendering instead of real-time rendering:
    • File > Export > Movie
    • Make Video Frame (specifying a timestamp other than "Auto") -> Save Frames to Movie"
  • Reduce image resolution or framerate
  • Use a faster Mac