Status: 

Vuo version: 

Steps causing the bug to occur: 

  1. Unzip and build customType_20210706 (attached).
  2. Open CremTypeTest.vuo (attached).
  3. Run.

An error dialog pops up with the following details:

Undefined symbols for architecture x86_64:
  "_CremTimecodeImage_getSummary", referenced from:
      _vuo_list_summarize_CremTimecodeImage__nodeEvent in composite-zSIGx8-77147a.o
  "_VuoListAppendValue_CremTimecodeImage", referenced from:
      _vuo_list_enqueue_CremTimecodeImage__nodeInstanceEvent in composite-zSIGx8-77147a.o
  "_VuoListCreate_CremTimecodeImage", referenced from:
      _vuo_list_enqueue_CremTimecodeImage__nodeInstanceInit in composite-zSIGx8-77147a.o
      _vuo_list_enqueue_CremTimecodeImage__nodeInstanceEvent in composite-zSIGx8-77147a.o
  "_VuoListGetCount_CremTimecodeImage", referenced from:
      _vuo_list_enqueue_CremTimecodeImage__nodeInstanceEvent in composite-zSIGx8-77147a.o
      _vuo_list_summarize_CremTimecodeImage__nodeEvent in composite-zSIGx8-77147a.o
  "_VuoListGetData_CremTimecodeImage", referenced from:
      _vuo_list_summarize_CremTimecodeImage__nodeEvent in composite-zSIGx8-77147a.o
  "_VuoListGetValue_CremTimecodeImage", referenced from:
      _vuo_list_enqueue_CremTimecodeImage__nodeInstanceEvent in composite-zSIGx8-77147a.o
  "_VuoListRemoveAll_CremTimecodeImage", referenced from:
      _vuo_list_enqueue_CremTimecodeImage__nodeInstanceEvent in composite-zSIGx8-77147a.o
  "_VuoListRemoveFirstValue_CremTimecodeImage", referenced from:
      _vuo_list_enqueue_CremTimecodeImage__nodeInstanceEvent in composite-zSIGx8-77147a.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Have you found a workaround?: 

Exporting the composition to an app works.

Compositions: 

AttachmentSize
Package icon customType_20210706.zip12.58 KB
Binary Data CremTypeTest.vuo2.67 KB