dark1hd's picture

Status: 

Vuo version: 

OS version: 

  • macOS 11

CPU architecture: 

Intel x86_64

How severely does this bug affect you?: 

●●●● — It prevents me from using Vuo at all.

Steps causing the bug to occur: 

  1. Dragging VUO file into a VDMX media bin
  2. Activating this file
  3. Wait some seconds
  4. VDMX alert "The Vuo composition you are trying to load (/Users/..../..../....) doesn't support the Image Generator protocol!"
  5. May be crash of VDMX or infinite loading

Have you found a workaround?: 

Nope

Other notes: 

Hello there! Sorry for my english.

I have some trouble with import any VUO file in VDMX. I checked this report but in my case protocol mode "Image Generator" doesn't help. I try to load example file like this but it doesn't work too. In screenshot i showed alert from example file.

Idk, but the problem may be using the demo version of VDMX and/or VUO. VDMX version is b0.8.7.2.4

Screenshots: 

Comments

Hi dark1hd

Joëlle's picture
Submitted by

Hi dark1hd

Jumping in here as I have just posted this last night on the VIDVOX forums. I've just about had it with VDMX. I had a big show on Saturday night, I spent 3 days troubleshooting, debugging, removing nodes I thought were problematic, stress tested my show for hours, restarting VDMX & fast clicking files in the media bin etc and was so sure I had it to a point where it was stable, and then I had the most insane issues just before showtime. I actually downloaded Resolume last night, I'm not sure if this is the solution but I don't know what else to do about this. CoGe was the only other app the supported Vuo natively and that is no longer supported on Catalina +. The issue is not so much that VDMX has bugs (I mean that IS a huge issue), but the real fear is the complete lack of support and communication by the founders and the fact that old issues from a year ago have appeared again. I am worried about the future of VDMX to be honest.

I have been waiting for this new Macbook which has landed today and I don't even know if VDMX works on the latest OS never mind that I have these problems on High Sierra. It's a total bummer, like they have abandoned the app. The support is non existent and I can't risk using it for much longer.

I had that same issue where it gave that error (out of the blue, for the first time 20 minutes before showtime on Saturday) saying the files were not Image Generators (they were) and I had literally tested this for 12 hours each day for 3 days.

I just need a simple 2 channel mixer with an effects layer and to be able to MIDI map Vuo sliders. I love Vuo, but I am not confident in VDMX at all. Many people feel this way by the sounds of it and from a number of Vuo x VDMX users I have been talking with.

The version of VDMX I was using was 8.7.2.7 but the issues were present in 8.7.2.9 as well. Edit: The version of Vuo was the latest one, but the previous version had the same issues. This is causing me super stress and I'm currently looking into other options.

After your message i began

dark1hd's picture
Submitted by

After your message i began try different versions of VDMX. Some versions simply crash on start, some have same problem, which i showed on the top. In my case helped version 8.7.2.7 https://discourse.vidvox.net/t/vdmx-beta-8-7-2-7-now-ready-for-testing/1459. Idk how this works, but this is works :D

Proof: https://tppr.me/V0xEz

As a result trouble is in VDMX, not in VUO. Thx to u for idea, @Joëlle

dark1hd yeah I'm using 8.7.2

Joëlle's picture
Submitted by

dark1hd yeah I'm using 8.7.2.7 and had that error for the first time on Saturday night. Please can you log any bugs with VDMX on their forum and through the app? See the response to my post on vidvox forum from Projectile Objects who works there, I did not know this.

jersmi I'm a bit fed up tbh, been super patient for really long and it feels like something has shifted on their side, they assure that support emails are being read but communication has dipped and it's not what it used to be. Nothing worse that out of the blue issues when I was so certain I had a stable set up.

@vuo team, is it best to report a VDMX and Vuo issues both here AND the vidvox forum? Or best to just do it there? What's the best way to make the process of logging these issues easiest for you and the VDMX devs?

dark1hd,

jmcc's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Not a bug

dark1hd,

We fixed problems running compositions on macOS 11 when we released Vuo 2.2.0. Based on log messages from VDMX, we think the problem is that VDMX5_b8.7.2.4 uses an earlier version of the Vuo framework. VDMX5_b8.7.2.7 and VDMX5_b8.7.2.9 both use a later Vuo.framework, 2.3.0. You switched to VDMX5_b8.7.2.7, which you said solved the problem for you. For other encountering a similar problem:

  • If you need to use the older VDMX5_b8.7.2.4, try using it on a system running macOS 10.15 or earlier
  • Try using VDMX5_b8.7.2.7 or VDMX5_b8.7.2.9
  • Try exporting compositions as FFGL plugins (which requires a Vuo Pro license) and using those in VDMX instead (You could test this by using the FFGL plugins in the composition gallery: https://vuo.org/composition/ffgl.)

Joëlle, and others encountering general problems using VDMX:

It might be best to report problems using Vuo compositions in VDMX to both us and the VIDVOX team. We can try to determine whether the issues are something we can fix in Vuo, or perhaps offer suggestions/workarounds. Note: Although we communicate with the VIDVOX team, we don't have access to or control over the VDMX code.