Status: 

Vuo version: 

OS version: 

  • macOS 12

CPU architecture: 

Apple Silicon (M1/ARM64)
Intel x86_64

How severely does this bug affect you?: 

●●○○ — It's annoying but I can work around it.

Steps causing the bug to occur: 

Let me start by saying this is not (necessarily) a particularly helpful bug report because I don't have the M1 on my desk for debugging purposes. But I'm reporting it in case it pops up for someone else, or if it confirms something already imagined.

I have a composition that plays 4K spherical movies. I originally developed it on Intel Mac Mini using version 2.2.1. The client then runs it on a M1 Mac Mini. No problems with that.

The composition provides the user the ability to scrub fast forward in the movie, I use the "Set Time" input to achieve this after getting the movie timestamp from the "Get Frames Values".

I then upgraded Vuo to 2.4. Now on the clients M1 the built app regularly crashes during fast forward.

As a test, I reverted to 2.2.1, no crashes.

Have you been able to reproduce the problem?: 

●●● — Yes, the problem occurs consistently when I follow the steps above

Have you found a workaround?: 

Build with version 2.2.1

Comments

As you guessed, we'll need

jstrecker's picture
Submitted by
Status:
Waiting for review by Vuo Support Team
»
Waiting for more information from reporter

As you guessed, we'll need more information to be able to debug the problem. If you or anyone else who runs into this problem can provide a crash report and a small composition plus movie demonstrating the problem, then we could make some progress.