quick vuo protocol patch running in VDMX 64 bit

Comments

Nice, does it take long to

Kino's picture
Submitted by

Nice, does it take long to trigger? I read in VDMX's note that compositions should get compiled and if you wanna use fast-triggered dylib then you can't play with the published parameters. Or did I get it all wrong?

Very good question. I was a

krezrock's picture
Submitted by

Very good question. I was a bit confused by that as well. If you disable "Vuo Runs in different Processes" the Vuo patch will trigger immediately. VDMX will not run an exported .app. It will run the .vuo file. All of the published ports become available in VDMX as expected. I believe if VDMX is set to have Vuo run in different processes, then it will try to reload the updated .vuo file.

Very awesome!

pingbird's picture
Submitted by

Very awesome!

I just started with vuo coming from QC - Exciting!

Yet, i am so failing to get controls to show up in vdmx.

I have tried "normal" and protocolled generator compositions, attaching the controls i want to the left side to publish. nothing shows up in vdmx.

when i run the comp, i get an image and dropped into vdmxs media bin, i also get an image - just no controls in interface panel.

Since you obviously achieved what i am struggling with, i thought i'd ask for pointers here.

i've attached my supersimple first try.

thanks for any pointers!

Hi there,

krezrock's picture
Submitted by

Hi there,

UI items of the appropriate type (presently, VDMX supports Integer/Real, Color, Boolean, Point2D, and Text-type inputs) will automatically be created for any published inputs in the vuo composition (likewise, data sources will be created for published outputs in the vuo comp).

The issue with your patch currently is the published ports are Point3D (array). So you will need to add Make 3D Point nodes for each Port on the Make 3D Transform node. Then publish the X, Y, Z inputs on the Make 3D Point nodes.

Enjoy!

I can not play a vuo imgae

p8guitar's picture
Submitted by

I can not play vuo image generators in vdmx. Does VDMX 0.8.5.0.7 support Vuo 1.2? I don't know if the composition is the cause (I just began learning vuo) or VDMX. I saved some example compositions (explodeclay and ShowLiveAudioTrail) with the image generator protocol and loaded them into a VDMX media bin. When I click on the clip, the vuo comp is shown in the vuo editor window, but it is not shown in VDMX. Then I loaded two example image generators. SpinKaleidoscope.vuo does not work, but GenerateCheckerboardImage.vuo is being played. ?!?

The "IMG_3752.mov" which might explain the whole thin can not be played, I get an error message that the file is damaged.

@p8guitar, for an image

jstrecker's picture
Submitted by

p8guitar, for an image generator to work in VDMX, you need to have cables connected to the published inputs and outputs (green sidebars). Notice the difference between your attached compositions and the ones under File > Open Example > Image Generators. Also see the Vuo Manual (PDF/HTML).

I'm not sure why SpinKaleidoscope.vuo wouldn't work but GenerateCheckerboardImage.vuo would. I just tested that SpinKaleidoscope.vuo does work in Vuo 1.1.1. In what way does it not work? Are there any messages in Console?

More info on VDMX + Vuo versions: Are there plans to make Vuo a system-wide service?

The "IMG_3752.mov" which might explain the whole thin can not be played, I get an error message that the file is damaged.

It plays OK for me in QuickTime Player. Maybe try downloading again?