jayeazy's picture

@jayeazy

jayeazy's picture
jayeazy commented on jayeazy's Bug Report, “RTSP Not working on Dahua IP Cams

@Jaymie , still not able to open rtsp stream.

Tried this with ffmpeg in terminal, and it creates a playable video file...... so don't know why VUO doesnt show the video....... If you could help makes this work somehow ?

ffmpeg -loglevel debug -rtsp_transport tcp -i "rtsp://jelte:4eyez8604@10.10.0.135:554/cam/realmonitor?channel=1&subtype=0" -c copy -map 0 foo.mp4

SDP:
v=0
o=- 2251938637 2251938637 IN IP4 0.0.0.0
s=Media Server
c=IN IP4 0.0.0.0
t=0 0
a=control:*
a=packetization-supported:DH
a=rtppayload-supported:DH
a=range:npt=now-
m=video 0 RTP/AVP 96
a=control:trackID=0
a=framerate:25.000000
a=rtpmap:96 H264/90000
a=fmtp:96 packetization-mode=1;profile-level-id=640029;sprop-parameter-sets=Z2QAKaw0zgeAIn5cBbgICAoAAAfQAAGGodDAAII8AACCPBd5caGAAQR4AAEEeC7y4UA=,aO48MA==
a=recvonly

[rtsp @ 0x7facd880b000] video codec set to: h264
[rtsp @ 0x7facd880b000] RTP Packetization Mode: 1
[rtsp @ 0x7facd880b000] RTP Profile IDC: 64 Profile IOP: 0 Level: 29
[rtsp @ 0x7facd880b000] Extradata set to 0x7facd8420cd0 (size: 62)
[rtsp @ 0x7facd880b000] setting jitter buffer size to 0
[rtsp @ 0x7facd880b000] hello state=0
Failed to parse interval end specification ''
[h264 @ 0x7facd880ec00] nal_unit_type: 7(SPS), nal_ref_idc: 3
[h264 @ 0x7facd880ec00] nal_unit_type: 8(PPS), nal_ref_idc: 3
[h264 @ 0x7facd880ec00] nal_unit_type: 7(SPS), nal_ref_idc: 3
[h264 @ 0x7facd880ec00] nal_unit_type: 8(PPS), nal_ref_idc: 3
[h264 @ 0x7facd880ec00] ct_type:1 pic_struct:0
[h264 @ 0x7facd880ec00] nal_unit_type: 9(AUD), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 7(SPS), nal_ref_idc: 3
[h264 @ 0x7facd880ec00] nal_unit_type: 8(PPS), nal_ref_idc: 3
[h264 @ 0x7facd880ec00] nal_unit_type: 6(SEI), nal_ref_idc: 0
    Last message repeated 2 times
[h264 @ 0x7facd880ec00] nal_unit_type: 5(IDR), nal_ref_idc: 3
[h264 @ 0x7facd880ec00] ct_type:1 pic_struct:0
[h264 @ 0x7facd880ec00] Format yuvj420p chosen by get_format().
[h264 @ 0x7facd880ec00] Reinit context to 1920x1088, pix_fmt: yuvj420p
[h264 @ 0x7facd880ec00] ct_type:1 pic_struct:0
[h264 @ 0x7facd880ec00] nal_unit_type: 9(AUD), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 6(SEI), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 1(Coded slice of a non-IDR picture), nal_ref_idc: 2
[h264 @ 0x7facd880ec00] ct_type:1 pic_struct:0
    Last message repeated 1 times
[h264 @ 0x7facd880ec00] nal_unit_type: 9(AUD), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 6(SEI), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 1(Coded slice of a non-IDR picture), nal_ref_idc: 2
[h264 @ 0x7facd880ec00] ct_type:1 pic_struct:0
    Last message repeated 1 times
[h264 @ 0x7facd880ec00] nal_unit_type: 9(AUD), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 6(SEI), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 1(Coded slice of a non-IDR picture), nal_ref_idc: 2
[h264 @ 0x7facd880ec00] ct_type:1 pic_struct:0
    Last message repeated 1 times
[h264 @ 0x7facd880ec00] nal_unit_type: 9(AUD), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 6(SEI), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 1(Coded slice of a non-IDR picture), nal_ref_idc: 2
[h264 @ 0x7facd880ec00] ct_type:1 pic_struct:0
    Last message repeated 1 times
[h264 @ 0x7facd880ec00] nal_unit_type: 9(AUD), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 6(SEI), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 1(Coded slice of a non-IDR picture), nal_ref_idc: 2
[h264 @ 0x7facd880ec00] ct_type:1 pic_struct:0
    Last message repeated 1 times
[h264 @ 0x7facd880ec00] nal_unit_type: 9(AUD), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 6(SEI), nal_ref_idc: 0
[h264 @ 0x7facd880ec00] nal_unit_type: 1(Coded slice of a non-IDR picture), nal_ref_idc: 2
[h264 @ 0x7facd880ec00] ct_type:1 pic_struct:0
    Last message repeated 21 times
[rtsp @ 0x7facd880b000] All info found
Input #0, rtsp, from 'rtsp://jelte:4eyez8604@10.10.0.135:554/cam/realmonitor?channel=1&subtype=0':
  Metadata:
    title           : Media Server
  Duration: N/A, start: 0.240000, bitrate: N/A
    Stream #0:0, 28, 1/90000: Video: h264 (High), 1 reference frame, yuvj420p(pc, bt709, progressive, left), 1920x1080 (1920x1088) [SAR 1:1 DAR 16:9], 0/1, 25 fps, 25 tbr, 90k tbn, 50 tbc
Successfully opened the file.
Parsing a group of options: output url foo.mp4.
Applying option c (codec name) with argument copy.
Applying option map (set input stream mapping) with argument 0.
Successfully parsed a group of options.
Opening an output file: foo.mp4.
[file @ 0x7facd8421f40] Setting default whitelist 'file,crypto'
Successfully opened the file.
Output #0, mp4, to 'foo.mp4':
  Metadata:
    title           : Media Server
    encoder         : Lavf58.19.100
    Stream #0:0, 0, 1/90000: Video: h264 (High), 1 reference frame (avc1 / 0x31637661), yuvj420p(pc, bt709, progressive, left), 1920x1080 (0x0) [SAR 1:1 DAR 16:9], 0/1, q=2-31, 25 fps, 25 tbr, 90k tbn, 90k tbc
Stream mapping:
  Stream #0:0 -> #0:0 (copy)
Press [q] to stop, [?] for help
cur_dts is invalid (this is harmless if it occurs once at the start per stream)
[mp4 @ 0x7facd880f200] Non-monotonous DTS in output stream 0:0; previous: 0, current: -17100; changing to 1. This may result in incorrect timestamps in the output file.
[mp4 @ 0x7facd880f200] Non-monotonous DTS in output stream 0:0; previous: 1, current: -14400; changing to 2. This may result in incorrect timestamps in the output file.
[mp4 @ 0x7facd880f200] Non-monotonous DTS in output stream 0:0; previous: 2, current: -10800; changing to 3. This may result in incorrect timestamps in the output file.
[mp4 @ 0x7facd880f200] Non-monotonous DTS in output stream 0:0; previous: 3, current: -7200; changing to 4. This may result in incorrect timestamps in the output file.
[mp4 @ 0x7facd880f200] Non-monotonous DTS in output stream 0:0; previous: 4, current: -3600; changing to 5. This may result in incorrect timestamps in the output file.
[mp4 @ 0x7facd880f200] Non-monotonous DTS in output stream 0:0; previous: 5, current: 0; changing to 6. This may result in incorrect timestamps in the output file.
[NULL @ 0x7facd880ec00] ct_type:1 pic_struct:0
    Last message repeated 13 times
[NULL @ 0x7facd880ec00] ct_type:1 pic_struct:0e=00:00:01.40 bitrate=5992.1kbits/s speed= 2.7x    
    Last message repeated 12 times
[NULL @ 0x7facd880ec00] ct_type:1 pic_struct:0e=00:00:01.92 bitrate=5461.5kbits/s speed=1.85x    
    Last message repeated 12 times
jayeazy's picture
jayeazy commented on Paul's Discussion, “rtsp

Hi Jaymie, tried all options, none of them work in VUO. No video at all.. just a black screen.

jayeazy's picture
jayeazy commented on Paul's Discussion, “rtsp

URL is displayed different in VLC display windows, but isn't...... so that's not the case.

Tried it with debug, no idea what isnt working..

Did some testing, had some issue with the foscam with higher bandwith and screen size. but not all the time. The Dahua rtsp keeps black....

# pid=9345  t= 99,1211s              VuoCompiler.cc:2094            getDependenciesForComposition()     Gathering dependencies for '/tmp/Dahua Test-CNt3OF.bc'…
# pid=9345  t= 99,1288s              VuoCompiler.cc:2158            getDependenciesForComposition()     Done.
# pid=9345  t= 99,1342s              VuoCompiler.cc:2755                                     link()     Linking '/tmp/Dahua Test-CNt3OF-resource0.dylib'…
# pid=9345  t= 99,3551s              VuoCompiler.cc:2910                                     link()     Done.
# pid=9345  t= 99,3561s              VuoCompiler.cc:2755                                     link()     Linking '/tmp/Dahua Test-CNt3OF.dylib'…
# pid=9345  t= 99,5993s              VuoCompiler.cc:2910                                     link()     Done.
# pid=9345  t= 99,6073s                VuoRunner.cc:1092                       replaceComposition()     Loading composition…
# pid=9345  t= 99,8742s                VuoRunner.cc:1137                       replaceComposition()         Done.
# pid=9667  t=  0.1439s             VuoGlContext.cc:50                     VuoGlContext_renderers()     Renderer 0: Intel HD 5000 (Iris)
# pid=9667  t=  0.1736s             VuoGlContext.cc:54                     VuoGlContext_renderers()         Online             : yes
# pid=9667  t=  0.1737s             VuoGlContext.cc:58                     VuoGlContext_renderers()         Accelerated        : yes
# pid=9667  t=  0.1738s             VuoGlContext.cc:63                     VuoGlContext_renderers()         Video memory       : 1536 MB
# pid=9667  t=  0.1738s             VuoGlContext.cc:68                     VuoGlContext_renderers()         Texture memory     : 1536 MB
# pid=9667  t=  0.1739s             VuoGlContext.cc:73                     VuoGlContext_renderers()         Display mask       : 0x1f
# pid=9667  t=  0.1741s             VuoGlContext.cc:77                     VuoGlContext_renderers()                              Apple Computer Inc: Color LCD (2012-W48)
# pid=9667  t=  0.1742s             VuoGlContext.cc:82                     VuoGlContext_renderers()         OpenGL version     : 4
# pid=9667  t=  0.1855s             VuoGlContext.cc:95                     VuoGlContext_renderers()         OpenGL 2           : Intel Iris Pro OpenGL Engine (2.1 INTEL-10.6.33) maxTextureSize=16384
# pid=9667  t=  0.1905s             VuoGlContext.cc:113                    VuoGlContext_renderers()         OpenGL Core Profile: Intel Iris Pro OpenGL Engine (4.1 INTEL-10.6.33) maxTextureSize=16384
# pid=9667  t=  0.1935s             VuoGlContext.cc:122                    VuoGlContext_renderers()         OpenCL supported   : yes
# pid=9667  t=  0.1937s             VuoGlContext.cc:50                     VuoGlContext_renderers()     Renderer 1: Apple Software Renderer (GenericFloat)
# pid=9667  t=  0.1939s             VuoGlContext.cc:54                     VuoGlContext_renderers()         Online             : yes
# pid=9667  t=  0.1940s             VuoGlContext.cc:58                     VuoGlContext_renderers()         Accelerated        : no
# pid=9667  t=  0.1941s             VuoGlContext.cc:73                     VuoGlContext_renderers()         Display mask       : 0x1f
# pid=9667  t=  0.1942s             VuoGlContext.cc:77                     VuoGlContext_renderers()                              Apple Computer Inc: Color LCD (2012-W48)
# pid=9667  t=  0.1943s             VuoGlContext.cc:82                     VuoGlContext_renderers()         OpenGL version     : 4
# pid=9667  t=  0.1972s             VuoGlContext.cc:95                     VuoGlContext_renderers()         OpenGL 2           : Intel Iris Pro OpenGL Engine (2.1 INTEL-10.6.33) maxTextureSize=16384
# pid=9667  t=  0.2024s             VuoGlContext.cc:113                    VuoGlContext_renderers()         OpenGL Core Profile: Intel Iris Pro OpenGL Engine (4.1 INTEL-10.6.33) maxTextureSize=16384
# pid=9667  t=  0.2050s             VuoGlContext.cc:122                    VuoGlContext_renderers()         OpenCL supported   : no
# pid=9667  t=  0.2052s             VuoGlContext.cc:139                    VuoGlContext_renderers()     Driver: AppleIntelHD5000Graphics
# pid=9667  t=  0.2106s             VuoGlContext.cc:352                             createContext()     Created OpenGL context 0x7fb23a089c00 on Intel HD 5000 (Iris)
# pid=9667  t=  0.2317s           VuoGraphicsView.m:439                -[VuoGraphicsView drawRect:]     OpenGL context 0x7fb238859400's virtual screen changed to 0
# pid=9667  t=  0.2857s                 VuoAudio.cc:499                     VuoAudioOut_getShared()     Using default device #2, name "Apple Inc.: Built-in Output".
[20:15:37.368] FigByteFlumeCustomURLOpen signalled err=-12936 (kFigByteFlumeError_BadState) (no provider) at /SourceCache/CoreMedia/CoreMedia-1562.240/Prototypes/FigHTTP/FigByteFlumeCustomURL.c line 1486
# pid=9667  t=  0.2926s         VuoAvPlayerObject.m:297                -[VuoAvPlayerObject setURL:]     AvFoundation cannot play this asset (isPlayable=0, hasProtectedContent=0, isReadable=0).
[rtsp @ 0x7fb23c000000] SDP:
v=0
o=- 2251938844 2251938844 IN IP4 0.0.0.0
s=Media Server
c=IN IP4 0.0.0.0
t=0 0
a=control:*
a=packetization-supported:DH
a=rtppayload-supported:DH
a=range:npt=now-
m=video 0 RTP/AVP 96
a=control:trackID=0
a=framerate:25.000000
a=rtpmap:96 H264/90000
a=fmtp:96 packetization-mode=1;profile-level-id=4D0029;sprop-parameter-sets=Z00AKZpkA8ARPy4C3AQEBQAAAwPoAADDUOhgAEEeAABBHgu8uNDAAII8AACCPBd5cKAA,aO48gAA=
a=recvonly

# pid=9667  t=  0.5394s         VuoFfmpegDecoder.cc:125                                Initialize()     FFmpeg context flags: 0x0
# pid=9667  t=  0.5395s         VuoFfmpegDecoder.cc:131                                Initialize()     FFmpeg input format : 'RTSP input' (rtsp)  flags=0x1  codec=0x0
# pid=9667  t=  1.7724s         VuoFfmpegDecoder.cc:188                           InitializeVideo()     FFmpeg video codec  : 'H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10' (h264)
[swscaler @ 0x7fb23b13e200] deprecated pixel format used, make sure you did set range correctly
# pid=9667  t=  1.8298s                VuoGlPool.cc:319   VuoGlTexture_getMaximumTextureBytes_block()   1305 MB
[rtsp @ 0x7fb23c000000] method PAUSE failed: 455 Method Not Valid in This State
[h264 @ 0x7fb23883bc00] Missing reference picture, default is 0
[h264 @ 0x7fb23883bc00] decode_slice_header error
[swscaler @ 0x7fb238af4c00] deprecated pixel format used, make sure you did set range correctly
[swscaler @ 0x7fb239348a00] deprecated pixel format used, make sure you did set range correctly
[rtsp @ 0x7fb23c000000] method PAUSE failed: 455 Method Not Valid in This State
[h264 @ 0x7fb23883bc00] Missing reference picture, default is 0
[h264 @ 0x7fb23883bc00] decode_slice_header error
# pid=9667  t=  7.0600s           VuoVideoPlayer.cc:74                                     Create()     Using FFmpeg video decoder despite optimization preference.
# pid=9667  t=  7.0611s         VuoDisplayRefresh.c:125          VuoDisplayRefresh_enableTriggers()     Refresh: 59.9903 Hz (337750000/5630080)
# pid=9667  t=  7.0612s         VuoDisplayRefresh.c:134          VuoDisplayRefresh_enableTriggers()     Latency: unknown
# pid=9345  t=107,8879s                VuoRunner.cc:2709                   stopBecauseLostContact()     The connection between the composition ('VuoCompositionLoader') and runner timed out while listening for telemetry.
jayeazy's picture
jayeazy posted a new Bug Report, “RTSP Not working on Dahua IP Cams

RTSP Not working on Dahua IP Cams

jayeazy's picture

Status: 

Vuo version: 

OS version: 

  • Mac OS 10.10

How severely does this bug affect you?: 

●●●○ — It prevents me from completing a specific task with Vuo.

Steps causing the bug to occur: 

1.RTSP Stream doesn't work with DAHUA Web cam.

Have you found a workaround?: 

No

Other notes: 

VLC Does seem to play the same RTSP stream.... properly.... ERROR from debug:

# pid=9345  t= 99,1211s              VuoCompiler.cc:2094            getDependenciesForComposition()     Gathering dependencies for '/tmp/Dahua Test-CNt3OF.bc'…
# pid=9345  t= 99,1288s              VuoCompiler.cc:2158            getDependenciesForComposition()     Done.
# pid=9345  t= 99,1342s              VuoCompiler.cc:2755                                     link()     Linking '/tmp/Dahua Test-CNt3OF-resource0.dylib'…
# pid=9345  t= 99,3551s              VuoCompiler.cc:2910                                     link()     Done.
# pid=9345  t= 99,3561s              VuoCompiler.cc:2755                                     link()     Linking '/tmp/Dahua Test-CNt3OF.dylib'…
# pid=9345  t= 99,5993s              VuoCompiler.cc:2910                                     link()     Done.
# pid=9345  t= 99,6073s                VuoRunner.cc:1092                       replaceComposition()     Loading composition…
# pid=9345  t= 99,8742s                VuoRunner.cc:1137                       replaceComposition()         Done.
# pid=9667  t=  0.1439s             VuoGlContext.cc:50                     VuoGlContext_renderers()     Renderer 0: Intel HD 5000 (Iris)
# pid=9667  t=  0.1736s             VuoGlContext.cc:54                     VuoGlContext_renderers()         Online             : yes
# pid=9667  t=  0.1737s             VuoGlContext.cc:58                     VuoGlContext_renderers()         Accelerated        : yes
# pid=9667  t=  0.1738s             VuoGlContext.cc:63                     VuoGlContext_renderers()         Video memory       : 1536 MB
# pid=9667  t=  0.1738s             VuoGlContext.cc:68                     VuoGlContext_renderers()         Texture memory     : 1536 MB
# pid=9667  t=  0.1739s             VuoGlContext.cc:73                     VuoGlContext_renderers()         Display mask       : 0x1f
# pid=9667  t=  0.1741s             VuoGlContext.cc:77                     VuoGlContext_renderers()                              Apple Computer Inc: Color LCD (2012-W48)
# pid=9667  t=  0.1742s             VuoGlContext.cc:82                     VuoGlContext_renderers()         OpenGL version     : 4
# pid=9667  t=  0.1855s             VuoGlContext.cc:95                     VuoGlContext_renderers()         OpenGL 2           : Intel Iris Pro OpenGL Engine (2.1 INTEL-10.6.33) maxTextureSize=16384
# pid=9667  t=  0.1905s             VuoGlContext.cc:113                    VuoGlContext_renderers()         OpenGL Core Profile: Intel Iris Pro OpenGL Engine (4.1 INTEL-10.6.33) maxTextureSize=16384
# pid=9667  t=  0.1935s             VuoGlContext.cc:122                    VuoGlContext_renderers()         OpenCL supported   : yes
# pid=9667  t=  0.1937s             VuoGlContext.cc:50                     VuoGlContext_renderers()     Renderer 1: Apple Software Renderer (GenericFloat)
# pid=9667  t=  0.1939s             VuoGlContext.cc:54                     VuoGlContext_renderers()         Online             : yes
# pid=9667  t=  0.1940s             VuoGlContext.cc:58                     VuoGlContext_renderers()         Accelerated        : no
# pid=9667  t=  0.1941s             VuoGlContext.cc:73                     VuoGlContext_renderers()         Display mask       : 0x1f
# pid=9667  t=  0.1942s             VuoGlContext.cc:77                     VuoGlContext_renderers()                              Apple Computer Inc: Color LCD (2012-W48)
# pid=9667  t=  0.1943s             VuoGlContext.cc:82                     VuoGlContext_renderers()         OpenGL version     : 4
# pid=9667  t=  0.1972s             VuoGlContext.cc:95                     VuoGlContext_renderers()         OpenGL 2           : Intel Iris Pro OpenGL Engine (2.1 INTEL-10.6.33) maxTextureSize=16384
# pid=9667  t=  0.2024s             VuoGlContext.cc:113                    VuoGlContext_renderers()         OpenGL Core Profile: Intel Iris Pro OpenGL Engine (4.1 INTEL-10.6.33) maxTextureSize=16384
# pid=9667  t=  0.2050s             VuoGlContext.cc:122                    VuoGlContext_renderers()         OpenCL supported   : no
# pid=9667  t=  0.2052s             VuoGlContext.cc:139                    VuoGlContext_renderers()     Driver: AppleIntelHD5000Graphics
# pid=9667  t=  0.2106s             VuoGlContext.cc:352                             createContext()     Created OpenGL context 0x7fb23a089c00 on Intel HD 5000 (Iris)
# pid=9667  t=  0.2317s           VuoGraphicsView.m:439                -[VuoGraphicsView drawRect:]     OpenGL context 0x7fb238859400's virtual screen changed to 0
# pid=9667  t=  0.2857s                 VuoAudio.cc:499                     VuoAudioOut_getShared()     Using default device #2, name "Apple Inc.: Built-in Output".
[20:15:37.368] FigByteFlumeCustomURLOpen signalled err=-12936 (kFigByteFlumeError_BadState) (no provider) at /SourceCache/CoreMedia/CoreMedia-1562.240/Prototypes/FigHTTP/FigByteFlumeCustomURL.c line 1486
# pid=9667  t=  0.2926s         VuoAvPlayerObject.m:297                -[VuoAvPlayerObject setURL:]     AvFoundation cannot play this asset (isPlayable=0, hasProtectedContent=0, isReadable=0).
[rtsp @ 0x7fb23c000000] SDP:
v=0
o=- 2251938844 2251938844 IN IP4 0.0.0.0
s=Media Server
c=IN IP4 0.0.0.0
t=0 0
a=control:*
a=packetization-supported:DH
a=rtppayload-supported:DH
a=range:npt=now-
m=video 0 RTP/AVP 96
a=control:trackID=0
a=framerate:25.000000
a=rtpmap:96 H264/90000
a=fmtp:96 packetization-mode=1;profile-level-id=4D0029;sprop-parameter-sets=Z00AKZpkA8ARPy4C3AQEBQAAAwPoAADDUOhgAEEeAABBHgu8uNDAAII8AACCPBd5cKAA,aO48gAA=
a=recvonly

# pid=9667  t=  0.5394s         VuoFfmpegDecoder.cc:125                                Initialize()     FFmpeg context flags: 0x0
# pid=9667  t=  0.5395s         VuoFfmpegDecoder.cc:131                                Initialize()     FFmpeg input format : 'RTSP input' (rtsp)  flags=0x1  codec=0x0
# pid=9667  t=  1.7724s         VuoFfmpegDecoder.cc:188                           InitializeVideo()     FFmpeg video codec  : 'H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10' (h264)
[swscaler @ 0x7fb23b13e200] deprecated pixel format used, make sure you did set range correctly
# pid=9667  t=  1.8298s                VuoGlPool.cc:319   VuoGlTexture_getMaximumTextureBytes_block()   1305 MB
[rtsp @ 0x7fb23c000000] method PAUSE failed: 455 Method Not Valid in This State
[h264 @ 0x7fb23883bc00] Missing reference picture, default is 0
[h264 @ 0x7fb23883bc00] decode_slice_header error
[swscaler @ 0x7fb238af4c00] deprecated pixel format used, make sure you did set range correctly
[swscaler @ 0x7fb239348a00] deprecated pixel format used, make sure you did set range correctly
[rtsp @ 0x7fb23c000000] method PAUSE failed: 455 Method Not Valid in This State
[h264 @ 0x7fb23883bc00] Missing reference picture, default is 0
[h264 @ 0x7fb23883bc00] decode_slice_header error
# pid=9667  t=  7.0600s           VuoVideoPlayer.cc:74                                     Create()     Using FFmpeg video decoder despite optimization preference.
# pid=9667  t=  7.0611s         VuoDisplayRefresh.c:125          VuoDisplayRefresh_enableTriggers()     Refresh: 59.9903 Hz (337750000/5630080)
# pid=9667  t=  7.0612s         VuoDisplayRefresh.c:134          VuoDisplayRefresh_enableTriggers()     Latency: unknown
# pid=9345  t=107,8879s                VuoRunner.cc:2709                   stopBecauseLostContact()     The connection between the composition ('VuoCompositionLoader') and runner timed out while listening for telemetry.

Pages