pbourke's picture

Paul (@pbourke)

Groups

    Compositions

    4 years ago
    4 years ago
    4 years ago
    pbourke's picture
    Paul commented on Paul's Bug Report, “warp image node problem

    And noting that I am confident the warp mesh files are OK since they function as expected in other software that supports that format.

    pbourke's picture
    Paul commented on Paul's Bug Report, “warp image node problem

    Note that I am not concerned with the rough outline ... I know why that is. The issue is that by simply flipping the mesh vertically means it stops working.

    pbourke's picture
    Paul posted a new Bug Report, “warp image node problem

    warp image node problem

    Status: 

    Vuo version: 

    Fixed in Vuo version: 

    OS version: 

    • macOS 10.13

    Steps causing the bug to occur: 

    1. In the attachment there is a simple composition.
    2. There are also two warp datafiles, good and nogood.
    3. Good works, nogood gives me a black window.
    4. But the only difference between them is the y coordinate is inverted (*-1).

    Compositions: 

    AttachmentSize
    Package icon Archive.zip404.88 KB
    pbourke's picture
    Paul commented on Paul's Discussion, “works on one mac not another

    OK, here's some weird stuff, see also new attachment.

    Change

          if (mu2 >= 0.0 && mu2 <= 1.0 && mu1 >= 0.0) {
                found = k;
                break;
            }

    to

          found = k;
            if (mu2 >= 0.0 && mu2 <= 1.0 && mu1 >= 0.0) {
                break;
            }

    And it works. Scream! Why! For example change to

         gl_FragColor = vec4(found/24.0,found/24.0,found/24.0, 1.);

    and you can see the wedges (k) get identified correctly and "found" is not -1 but the wedge number.

    pbourke's picture
    Paul commented on Paul's Discussion, “works on one mac not another

    That is a possibility, you will note in my original query I suggested I started development on my MacBookPro ... I suspect I upgraded since then. Also, a colleague of mine I sent the project to had no problems, also MacBookPro, don't have his machine specs on hand.

    Pages