Windows Minimising/Maximising unexpectedly

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • macOS 10.14

Steps causing the bug to occur: 

  1. Run composition from this thread: https://vuo.org/node/2424
  2. Exit fullscreen
  3. Click up and down buttons multiple times.
  4. Output window keeps Minimising/Maximising randomly and unexpectedly.
  5. Same thing for me on two OS's and two different MBP's, 2012 OS 10.12 (GT650) and 2015 OS10.14 (Intel Iris Pro 1536 MB).

Other notes: 

I have not got any 'special window manager installed'.

Changing Syphon Server name from list

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • macOS 10.14

How severely does this bug affect you?: 

●●○○ — It's annoying but I can work around it.

Steps causing the bug to occur: 

  1. Load attached Comp
  2. Use on screen + and - Buttons to change Syphon Server Name
  3. The Syphon Server doesn't turn on

Have you found a workaround?: 

If I disconnect the cable going to the Server Name input of the Send Image via Syphon node and manually enter some text instead, run the comp, and then reconnect the cable the name change works as I expected it to. I haven't found a work around for this yet, instead I created 4 separate Mac Apps each manually named by the source rather than having one app that I can change the source name in.

Compositions: 

AttachmentSize
Binary Data Change Syphon Server Name.vuo6.13 KB

Crash when testing MakeRuggedTerrain.vuo example

eseftel's picture

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • macOS 10.14

How severely does this bug affect you?: 

●○○○ — Not much; I'm just letting you know about it.

Steps causing the bug to occur: 

  1. Open MakeRuggedaterrain.vuo example
  2. Edit-Protocol-Image Generator
  3. Connect Time input to MakeNoiseImage Roughness

Crash reports: 

AttachmentSize
Binary Data MakeRuggedTerrain.crash74.65 KB

Possible 'Receive Blackmagic Video' Node issue

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • macOS 10.14

How severely does this bug affect you?: 

●●○○ — It's annoying but I can work around it.

Steps causing the bug to occur: 

On an extremely complex composition that I can't unfortunatly post I couldn't get 2 Receive Blackmagic Video nodes using 2 Blackmagic UltraStudio Mini Recorders to work in the same composition properly. Watch link below to see an example of the issue. Each BM UltraStudio Mini Recorder has it's own address and can be used in OBS together and usually worked in a much simpler Vuo composition but has issues in the complex composition. What's even stranger is that swapping the BM node out of the receive live video node fixes the issue with nothing else changed so this has to be an issue with the BM node itself I think. Right?

I have tried to create a simpler composition showing the issue but only ran across the issue one other time. However after a reload of that project it started working properly and I wasn't able to recreate the issue on that project again.

Have you found a workaround?: 

Make sure you are using MacOS 10.14.3 or earlier. With nothing else changed I replaced one of the Receive Blackmagic Video nodes for a Receive Live Video node and this resolved the issue.

Other notes: 

Live video crashes/failures in macOS 10.14.4

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • macOS 10.14

Steps causing the bug to occur: 

In macOS 10.14.4, compositions with a Receive Live Video or List Video Devices node no longer work and sometimes crash.

The underlying problem is that, starting in macOS 10.14.4, a video library that Vuo uses (Apple’s QTKit) is broken. Other apps that use QTKit have also stopped working.

The problem will be fixed in Vuo 2.0, as it no longer relies on QTKit. See our mailing list / blog for updates on the estimated release date.

Have you found a workaround?: 

Downgrade to macOS 10.14.3 or earlier.

Pages

Subscribe to RSS - Resolved