On Mac OS 10.7 and 10.8, multiple windows cannot go fullscreen

mnstri's picture

Status: 

Vuo version: 

OS version: 

  • Mac OS 10.7

Steps causing the bug to occur: 

  1. On Mac OS 10.7, create a composition with 2 or more windows
  2. Move each window to a separate space and make it fullscreen

How did the result differ from what you expected?: 

Expect to be able to make multiple windows fullscreen simultaneously on separate screens

Have you found a workaround?: 

Upgrade to Mac OS 10.9 and check the System Preferences > Mission Control > Displays have separate Spaces checkbox

Other notes: 

The Composition Loader window cannot be moved or even activated when using 3d objects

mnstri's picture

Status: 

Vuo version: 

OS version: 

  • Mac OS 10.7

Steps causing the bug to occur: 

  1. Open any of the examples in vuo.scene category (or anything that uses 3d objects)
  2. Run it
  3. You will notice that you cant activate the composition loader window to bring it to front.
  4. You can't grab and move the window
  5. The "Make 3d Object" node seems to be what is causing it to happen

How did the result differ from what you expected?: 

I was expecting to be able to activate the window.

When did you first notice this bug?: 

Vuo 0.7

Have you found a workaround?: 

No

Other notes: 

I'm using Lion (10.7.5) and I'm not sure if Vuo is properly supported for that.

Jittering when using "Render Scene to Window" and "Render Image to Window" at the same time

mnstri's picture

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.7

Steps causing the bug to occur: 

  1. I'm not exactly sure what causes this, but the magic combination seems to be something like this:
  2. Create two or more 3d objects. "Make 3d Object From Image" seems to be the worst.
  3. Render them in the same composition to "Render Scene to Window" AND "Render Scene to Image" -> "Render Image to Window"
  4. Use "Fire Periodically" to update something in the composition periodically
  5. Run the composition
  6. The objects start to jitter. Like this

How did the result differ from what you expected?: 

I wasn't expecting the jittering

When did you first notice this bug?: 

0.5.2 (I'm pretty sure this wasn't there in 0.5.1)

Have you found a workaround?: 

no

Screenshots: 

Compositions: 

AttachmentSize
Binary Data jittering.vuo4.54 KB

input numbers with comma = not possible

Status: 

Duplicate of bug: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.7

Steps causing the bug to occur: 

  1. type a number in input port with comma: 0,1
  2. press key [enter]
  3. number is changed to 0, value: 0
  4. type number in input port with comma: 0,1
  5. press key [enter]
  6. number is changed to 1, value: 1
  7. doubleclick on inputport, value changes to 10000,000000
  8. press key [enter]
  9. number is changed to 1+e6 see also movie

How did the result differ from what you expected?: 

numbers should not change their values.

When did you first notice this bug?: 

from the beginning. everytime

Have you found a workaround?: 

no

Other notes: 

watch a screenflick of action:

Moderator note: 

Removed broken link

Pages

Subscribe to RSS - Mac OS 10.7