Editor: scale inputs in the node "Make Transform" not working properly

3lab_tv's picture

Status: 

Duplicate of bug: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.8

Steps causing the bug to occur: 

  1. Just tried to edit the input values from "scale"
  2. example: input 0,5 is not possible
  3. the values change to 1e+12

How did the result differ from what you expected?: 

formatting of the values from the "scale" input (i was not able to edit the value to 0,5 for example)

Have you found a workaround?: 

In System Preferences > Language & Text > Region > Numbers > Customize..., change the Decimal number separator to . (dot).

Other notes: 

Ok, just basics, but the "Make Transform" is one of the essential nodes

Screenshots: 

Can't open example compositions

synnack's picture

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.8

Steps causing the bug to occur: 

  1. Open Vuo Editor
  2. Click File, Open Composition
  3. Browse to downloads, DOUBLE-click vuo-0.5.0-composition-examples folder to enter it to select composition. Make sure "columns" view is enabled in finder, not list. (crash only happens in column view)
  4. Poof. Vuo editor crashes with "quit unexpectedly".
  5. Exception Type: EXC_BAD_ACCESS (SIGSEGV) Exception Codes: KERN_INVALID_ADDRESS at 0x00000000000000e8

How did the result differ from what you expected?: 

I expected to open a composition...

When did you first notice this bug?: 

Happens every time. I can't open any composition.

Have you found a workaround?: 

yes. This only happens if the Finder view is set to "columns" and the example folder is double clicked (instead of clicking once to just show the files inside it. If you use "list" view in Finder, you can actually drill into the examples folder and open compositions fine. The bug seems to only happen when double clicking your folder and only in the "columns" finder view.

Crash reports: 

Blank composition created when opening a composition

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.8

Steps causing the bug to occur: 

  1. Open up a composition, with the VUO editor unopen.
  2. A blank composition is created.

How did the result differ from what you expected?: 

I'd expect no blank composition to be created (hey all, I see the point of this form, but I'm bowing out of filling the rest out, in assumption that you get the gist of it.)

Major visual glitching when running Vuo Scenes

Status: 

Vuo version: 

Fixed in Vuo version: 

OS version: 

  • Mac OS 10.8

Steps causing the bug to occur: 

  1. Open Vuo
  2. Open any prebuilt scene (other than console based output)
  3. Start scene
  4. Glitch town.
  5. Profit?

How did the result differ from what you expected?: 

Self explanatory.

When did you first notice this bug?: 

Downloaded 0.4.9, immediately occurs when starting scene.

Have you found a workaround?: 

Use a computer with a non-Radeon GPU (or, if your MacBook has multiple GPUs, switch to the non-Radeon GPU).

Other notes: 

The scene actually executes properly, you can see it between the glitch frames, for example the tennis scene works, but it's picking up other graphics data from somewhere.

Screenshots: 

Pages

Subscribe to RSS - Mac OS 10.8