timwessman's picture

@timwessman

Groups

    timwessman's picture

    I have HAP-codec on my system and it works with other software (VDMX, Compressor...). I guess HAP -codec is needed to view HAP-videos even in the Vuo-editor (which works)?

    And I tried to reinstall it, doesn't help.

    Do HAP-video player work on your system when composition is exported as standalone app?

    timwessman's picture

    HAP video don't work on exported Mac App

    Status: 

    Vuo version: 

    Fixed in Vuo version: 

    OS version: 

    • OS X 10.11

    How severely does this bug affect you?: 

    ●●●○ — It prevents me from completing a specific task with Vuo.

    Steps causing the bug to occur: 

    1. Create simple video player composition. With vuo.video.play and vuo.image.render.window
    2. Set Hap -encoded video as video URL
    3. Run composition -> Everything works (attached image: ScreenShotHapBug2.png)
    4. Export composition to Mac App
    5. Run exported mac app -> Video is not displayed (attached image: ScreenShotHapBug1.png)
    6. Check OSX error console (attached image: ScreenShotHapBug3.png)
    7. Do the same with other video types (at least h264) -> Works fine

    Have you found a workaround?: 

    No - only other codecs works (at least h264)

    Other notes: 

    Attached example project, which is source of screenshots.

    Screenshots: 

    Compositions: 

    AttachmentSize
    Package icon HapBug.zip12.06 MB
    timwessman's picture

    New test composition with another box drawn with layer.make.color as a comparison. Both boxes are drawn now at same position with same anchor position, but rounded rectacle jumps to different positions and layer.make.color -box works as it should.

    timwessman's picture

    Anchor points doesn't work (at least not in layer.make.roundedRectangle)

    Status: 

    Vuo version: 

    Fixed in Vuo version: 

    OS version: 

    • OS X 10.11

    How severely does this bug affect you?: 

    ●●●○ — It prevents me from completing a specific task with Vuo.

    Steps causing the bug to occur: 

    1. Create layer.make.roundedRectangle
    2. Set Anchor to any other anchor point than center
    3. Make rectangle height bigger than width
    4. Anchor point flips to another place

    Have you found a workaround?: 

    No

    Other notes: 

    If this is meant to work like this, please explain why, I don't understand the logic?

    Screenshots: 

    Compositions: 

    AttachmentSize
    Binary Data PositionBug.vuo7.67 KB

    Pages