pbourke's picture

Paul (@pbourke)

Groups

    Compositions

    5 years ago
    5 years ago
    5 years ago
    pbourke's picture
    Paul posted a new Bug Report, “Movie fast forward

    Movie fast forward

    Status: 

    Vuo version: 

    OS version: 

    • macOS 12

    CPU architecture: 

    Apple Silicon (M1/ARM64)
    Intel x86_64

    How severely does this bug affect you?: 

    ●●○○ — It's annoying but I can work around it.

    Steps causing the bug to occur: 

    Let me start by saying this is not (necessarily) a particularly helpful bug report because I don't have the M1 on my desk for debugging purposes. But I'm reporting it in case it pops up for someone else, or if it confirms something already imagined.

    I have a composition that plays 4K spherical movies. I originally developed it on Intel Mac Mini using version 2.2.1. The client then runs it on a M1 Mac Mini. No problems with that.

    The composition provides the user the ability to scrub fast forward in the movie, I use the "Set Time" input to achieve this after getting the movie timestamp from the "Get Frames Values".

    I then upgraded Vuo to 2.4. Now on the clients M1 the built app regularly crashes during fast forward.

    As a test, I reverted to 2.2.1, no crashes.

    Have you been able to reproduce the problem?: 

    ●●● — Yes, the problem occurs consistently when I follow the steps above

    Have you found a workaround?: 

    Build with version 2.2.1

    pbourke's picture
    Paul posted a new Discussion, “Intel vs M1
    pbourke's picture
    Paul posted a new Discussion, “Load scene (OBJ), textures and wrap modes

    Load scene (OBJ), textures and wrap modes

    I'm loading scenes as OBJ files with large texture maps, two observations

    1. There does not seem any way to clamp textures rather than the default wrap of textures. This basically stops me from abutting adjacent texture maps due to colour interpolation for texture coordinates of 0 (or 1) with the texture at 1 (or 0).

    pbourke's picture
    Paul commented on Paul's Bug Report, “Documentation suggestion, not a bug

    After some quick tests, in Vuo the FOV is currently measured horizontally. That's what should be added to the node documentation.

    Pages